home *** CD-ROM | disk | FTP | other *** search
/ Amiga Format CD 52 / Amiga Format AFCD52 (Issue 136, May 2000).iso / -screenplay- / shareware / freeciv / data / trident / cities.spec < prev    next >
Text File  |  2000-02-29  |  2KB  |  86 lines

  1. ;
  2. ; The names for city tiles are not free and must follow the following rules.
  3. ; The names consists of style name, _ , size. The style name is as specified
  4. ; in cities.ruleset file. The size indicates which size city must
  5. ; have to be drawn with a tile. E.g. european_4 means that the tile is to be
  6. ; used for cities of size 4+ in european style. Obviously the first tile
  7. ; must be style_name_0. The sizes must be in ascending order.
  8. ; There must also be a style_name_wall tile used to draw the wall and
  9. ; an occupied tile to indicate a miltary units in a city.
  10. ; The maximum size supported now is 31, but there can only be MAX_CITY_TILES
  11. ; normal tiles. The constant is defined in common/city.h and set to 8 now.
  12. ;
  13.  
  14. [spec]
  15.  
  16. ; Format and options of this spec file:
  17. options = "+spec2"
  18.  
  19. [info]
  20.  
  21. artists = "
  22.     Jerzy Klek <jekl@altavista.net>
  23.  
  24.     european style based on trident tileset by
  25.     Tatu Rissanen <tatu.rissanen@hut.fi>
  26.     Marco Saupe <msaupe@saale-net.de> (reworked classic, industrial and modern)
  27. "
  28.  
  29. [file]
  30. gfx = "trident/cities"
  31.  
  32. [grid_main]
  33.  
  34. x_top_left = 0
  35. y_top_left = 0
  36. dx = 30
  37. dy = 30
  38.  
  39. tiles = { "row", "column", "tag"
  40.  
  41. ; default tiles
  42.  
  43.  1,  2, "cd.city"
  44.  1,  3, "cd.city_wall"
  45.  1,  4, "cd.occupied"
  46.  
  47. ; used by all city styles
  48.  
  49.  0,  0, "city.disorder"
  50.  
  51. ;
  52. ; city tiles
  53. ;
  54.  
  55.  1,  0, "city.european_0"
  56.  1,  1, "city.european_5"
  57.  1,  2, "city.european_10"
  58.  1,  3, "city.european_wall"
  59.  1,  4, "city.european_occupied"
  60.  
  61.  5,  0, "city.classical_0"
  62.  5,  1, "city.classical_5"
  63.  5,  2, "city.classical_10"
  64.  5,  3, "city.classical_wall"
  65.  5,  4, "city.classical_occupied"
  66.  
  67.  2,  0, "city.industrial_0"
  68.  2,  1, "city.industrial_5"
  69.  2,  2, "city.industrial_10"
  70.  2,  3, "city.industrial_wall"
  71.  2,  4, "city.industrial_occupied"
  72.  
  73.  3,  0, "city.modern_0"
  74.  3,  1, "city.modern_5"
  75.  3,  2, "city.modern_10"
  76.  3,  3, "city.modern_wall"
  77.  3,  4, "city.modern_occupied"
  78.  
  79.  4,  0, "city.postmodern_0"
  80.  4,  1, "city.postmodern_5"
  81.  4,  2, "city.postmodern_10"
  82.  4,  3, "city.postmodern_wall"
  83.  4,  4, "city.postmodern_occupied"
  84.  
  85. }
  86.